Scroll

DR - Apteryx Auto-Export (non-MacPractice Feature)

This is a non-MacPractice Support feature. If you have any additional questions on this setup, please contact the Apteryx Vendor directly.

HOW-TO:

AUTOMATE THE IMAGE EXPORT PROCESS (AUTO-EXPORTS)

When bridging images from the XrayVision to other applications, it sometimes become necessary to export the image to a predefined directory and file format. To expedite repetitive exports, the XrayVision supports Auto Export definitions. Auto Export definitions define a directory, filename and file format that should be used when exporting an image. Auto Export definitions automatically export the image to the specified filename and directory simply by selecting the appropriate Auto Export definition.

Creating an Auto Export definition

To create an auto export definition:

Select File > Auto Export > Auto Exports from the menu.

The 'Auto Exports' dialog box appears. Click on the New button.

Enter a name to identify this auto export (e.g. "YahooEmail") and then click on the Next button.

 

Select the target path where files are to be exported (i.e. "C:\Temp") and then click on the Next button. (Either type the path manually or browse/select the path by clicking on the  button.) 

Select the Save the image to an automatically generated filename option and then click on the Next button.

Select Include patient information in filenameNote: If selected, filename generated will include patient's first name, last name, and SS#. If not, the current, day, date, and time will be used to name the file. Select Use the following file extension and enter "jpg" in the 'File Extension' field. Click on the Next button.

Select Jpeg Image from the 'Image File Format' drop-down list and then click on the Finish button.

The new auto-export definition will be listed on the 'Auto Exports' dialog box. Click on the Done button.

 

Once created, the definition can be used to quickly export open images to the location specified in Step 4 above.

Auto-Exporting an Image

The image to be exported must opened and displayed on the XV desktop.

Select File > Auto Exports and then select the auto-export definition created. The image will be exported to the specified location. 


Add the Export button to the XrayVision toolbar

Under the Tools menu, select Customize Toolbar…
In the Customize Toolbar window, click the button Add/Insert New.

Within the Command and Graphic Selection window, choose the following options:

  • Category: File
  • Commands: Auto Export -> Dentrix Export
  • Graphic: Choose a button graphic, or click “Select the current command’s default image”
    HOWTO__Automatically_Send_Images_from_XrayVision_to_Dentrix_Document_Center-add_button.jpg

Click OK. The button will be added to the bottom of the list. You can then rearrange the order of the buttons, or simply click OK.

A button labeled Dentrix Export should now appear in the XrayVision toolbar. 

HOWTO__Automatically_Send_Images_from_XrayVision_to_Dentrix_Document_Center-Dentrix_Export_Button.jpg

Setup Dentrix Document Center

Open Dentrix Document Center.
Under the Acquire menu, choose Auto Directory File Acquire. The Setup Acquisition Method Defaults window will appear.

HOWTO__Automatically_Send_Images_from_XrayVision_to_Dentrix_Document_Center-setup_dentrix.jpg

Specify the following options: 

  • Document Type: Select the default document type, for example X-rays 
  • Description: Type a default description. This can be changed later. Example: Apteryx export 
  • Orientation: Select a default orientation for the image (optional). 
  • Scanner Import Folder: Type the path where XrayVision Auto Exports will be saved. Example: C:\Dentrix-Import

Click Save and Close.

Test the Auto Export / Auto Import functionality 
With the correct patient open in both the Dentrix Document Center and XrayVision, do the following:

Open one of the patient’s images in XrayVision, and click the Dentrix Export button.
Switch back to the Dentrix Document Center window.

In a few seconds, the Dentrix Document Center should display a new Document Information window, with the default settings that were previously chosen for the Document Type and Description. From here you can modify the Reference Date, Document Type, and Description, and also add Notes.
Once you are finished, click OK. 

HOWTO__Automatically_Send_Images_from_XrayVision_to_Dentrix_Document_Center-doc_info.jpg

The image should now appear in the Dentrix Document Center record for the patient.

HOWTO_-_Automatically_Send_Images_from_XrayVision_to_Dentrix_Document_Center-dcc.jpg

Was this article helpful?
0 out of 0 found this helpful

Comments