Scroll

General Navigation - Menu Bar

The Menu Bar is the bar at the very top of the macOS view, that indicates which application you're in. This article will cover all the options available within the Menu Bar when MacPractice is the active application.

MacPractice Menu

The MacPractice Menu contains options to help you manage your MacPractice installation, including options to update your software build, and Preferences to adjust broad behaviors within MacPractice.

Screen_Shot_2020-11-13_at_1.37.07_PM.png


The MacPractice Menu contains:

  • About: The About MacPractice Window lists key information about the MacPractice installation including the version number, local IP address, serial number, and database name. The About MacPractice window also lists the certificate SHA1 fingerprint, which can be used for Server Certificate Authorization.
  • Update MacPractice: This option will open up a window that checks if there is a new update available to your office. If there is no update available, a prompt will alert you to this.
  • Update Codes: This option will take you to the Downloads page where you can download an updated package of the Reference Concept Database. This contains all updated diagnosis codes, NDC codes, and other relevant codes used in MacPractice.
  • Server Management App (12.11 and up): This option will open up the Server Management App, which can be used to manage the processes that run the MacPractice server. This is only available in MacPractice Build 12.11, and you can read more about the Server Management App here.
  • Preferences: Opens the MacPractice Preferences. This is where you can customize many behaviors within MacPractice.
  • Services: Opens a submenu of Services.
  • Hide: Hides all MacPractice windows currently open, and brings forward the most recent.
  • Hide Others: Hides all MacPractice windows, apart from the currently displayed window.
  • Show All: Displays all open MacPractice windows.
  • Quit: Quits MacPractice.

File Menu

The File Menu displays items that apply to specific files or documents.

Screen_Shot_2020-11-13_at_2.50.48_PM.png

The File Menu contains standard menu items, typically found in other Mac OS X applications, such as:

  • New Window: Opens a New MacPractice window..
  • Close: Closes the active MacPractice window.
  • Import: This section contains Importing options for Codes, Note Templates, and QRDA Cat 1. All three options will open a file selection window where you can select the appropriate file.
  • Export: This section contains Exporting options for several pieces of MacPractice data. Please review our Exporting section below for more details.
  • Retrieve Archived: This option allows you to retrieve a wide variety of archived data from across MacPractice. You can read more about it in the Retrieving an Archived or Deleted Patient article here.
  • Generate File Fingerprint: This option is used to create a file fingerprint, or hash, for an exported file. With a fingerprint in place, the file can be verified to determine if it has been changed. You can read more below.
  • Verify File Fingerprint: This option is used to test the validity of a generated File Fingerprint file. You can read more below.
  • Encrypt/Decrypt: The Encrypt/Decrypt item encrypts and decrypts an exported file for the purposes of security.
  • Page Setup: Opens the print parameters dialog.
  • Print: Opens the Print dialog.
  • When selected, you will be prompted to select a file to verify the file fingerprint (hash).

 

Generating and Verifying File Fingerprints
Generate File Fingerprint is used to create a file fingerprint, or hash, for an exported file. With a fingerprint in place, the file can be verified to determine if it has been changed.
To create a file fingerprint (hash) for any exported file, such as reports or patient data, select Generate File Fingerprint. From the resulting menu, select the exported file and click the Open button to generate the file's fingerprint.

Once the fingerprint is generated, click the OK button. The fingerprint (hash) file will be generated with the original file name, including the format SHA256.

File Fingerprinting uses a SHA-256 algorithm to verify data if changed in a file. The SHA-256 (i.e.: SHA-2) hash function is used in as security in applications and protocols and serves as the secure algorithm required by US Government applications and commercial applications with sensitive data. More information can be found in NIST's Policy on Hash Functions.
To verify a file's Fingerprint, you can select Verify File Fingerprint to test the validity of a generated File Fingerprint file. From the resulting menu, select the fingerprint file with the .SHA256 extension, then click the Open button.
 
If changes have not been made, the resulting verification window will indicate that the verification has passed. If the fingerprinted file has been changed, the notification window will indicate a verification failure, such as the fingerprint file was not created or the fingerprint file has been modified.
If the fingerprinted file has been separated from the file fingerprint (hash) file, the verification process will not function properly. The file fingerprint, with extension .SHA256, should always be located with the fingerprinted file.
Encrypting and Decrypting Files
The Encrypt/Decrypt item encrypts and decrypts an exported file for the purposes of security. To encrypt or decrypt a file select the File menu and choose the Encrypt/Decrypt item. The submenu includes items to Encrypt File and Decrypt File.
 
Screen_Shot_2017-05-05_at_12.07.39_PM.png

The Encrypt/Decrypt item uses the AES-256 (Advanced Encryption Standard) encryption method, the same symmetric key encryption used by the US Government.
 

Edit Menu

The Edit menu displays items that edit and manipulate information.

Screen_Shot_2020-11-20_at_12.45.55_PM.png


The Edit menu contains standard menu items, typically found in other Mac OS X applications, such as:

  • Undo: Reverts the previous action.
  • Redo: Reverts the previous Undo action.
  • Cut: Copies and cuts the selected data.
  • Copy: Copies the selected data.
  • Paste: Pastes the copied data.
  • Paste & Match Style: Pastes the copied data while matching surrounding text style (font, size, color, and so on).
  • Delete: Deletes the selected data.
  • Select All: Selects all contents within a field.
  • Special Characters: Opens the Special Characters window to input Mac OS X supported characters.
Some menu items are MacPractice specific, such as:
  • New Record: Creates a new record.
  • Delete Record: Deletes the selected record.
  • Save Record: Saves the selected record.
  • Revert Record: Reverts all previous actions to the selected record.
  • Clear Record: Removes all data from the selected record.
  • Duplicate Record: Creates a copy of the selected record.

View Menu

Screen_Shot_2020-11-20_at_1.36.02_PM.png

The View menu displays items that maneuver to MacPractice abilities, or views.

  • Show Tab Bar: On macOS High Sierra and up, this will display the Tab Bar in the MacPractice software just below the Toolbar.
  • Show All Tabs: On macOS High Sierra and up, this will display all currently open tabs. Currently, you can only open one tab.
  • Inspector: This will open up the Inspector pane, which provides options depending on where you are in MacPractice. 
  • Reload: Reloads the current view.
  • Search: Places the cursor within the search field of the view.
  • Toggle One/Many: Activates One or Many mode.
  • Abilities: You can toggle between some of the most used Abilities from the View Menu. You can also see the keyboard shortcuts for those Abilities you can switch to from here.
  • Back: Retrieves the previous view.
  • Next: Advances the View.
  • Zoom In: Zooms in.
  • Zoom Out: Zooms out.
  • Actual Size: In areas where you can adjust the zoom, this will switch back to the default view.
  • Customize Toolbar: Opens the toolbar customization menu.
  • Enter Full Screen: Toggles the window to full screen.
Text Menu
Screen_Shot_2020-11-23_at_8.54.25_AM.png
The Text Menu helps adjust properties when in certain text processing fields, such as in the Notes Ability.
  • Font: Opens a submenu of font specific items, such as Bold, Italic, and so on.
  • Text: Opens a submenu of text alignment items, such as Center, Justify, Align Left, and so on.
  • Find: Opens a submenu of find items, such as Find, Find Next, Find Previous.
  • Spelling: Opens the Spelling and Grammar dialogue.
  • Search Notes: In the Notes Ability, this will open up a search prompt that will allow you to search for a specific Note by Patient Name, Note Title, or Date. 
  • Move Note to Locked: In the Notes Ability, you can use this option to move a Note to the Locked node.
  • Header: This option in Notes allows you to enable and adjust the margins of the header.
  • Margins: This option in Notes allows you to enable and adjust the margins of the footer.
  • Image: In the Notes Ability, these options allow you to rotate clockwise and counterclockwise.
  • Table: In the Notes Ability, this option opens a window where you can create a table. You have options to set the number of rows and columns, and other formatting options.
  • Insert Page Break: In the Notes Ability, this will place a Page Break in the current note.

Window Menu

Screen_Shot_2020-11-23_at_10.57.37_AM.png

The Window menu contains standard menu items, typically found in other Mac OS X applications, such as:

  • Zoom: Toggles from the window sized currently set to a predefined window size, designed for the window's content.
  • Minimize: Minimizes the current window to the Dock.
  • Online Users: Opens a dialogue that displays all users currently logged in to the MacPractice database.
  • Lists: This will open up the Lists Window.
  • Time Clock Panel: This will open up the Time Clock panel for the currently logged in user.
  • Palettes: Opens a window used as a palette for pull-fields when creating Forms and Notes.
  • Tasks: Opens a dialogue that displays all tasks currently running in the MacPractice background.
  • Database Processes: Opens a dialogue that lists the running MYSQL processes.
  • Patient Information: Opens a palette that lists a patient insurance information in the Patients ability.
  • Jive Communicator: If you have the Jive purchased option on your license, this will bring up the Jive Communicator where you can dial out. You can read more about our Jive integration here.
  • Bring All to Front: Brings forth all open MacPractice windows.

Help Menu

Screen_Shot_2020-11-23_at_11.39.03_AM.png

The Help menu contains the following options.

  • MacPractice HelpDesk: Opens the MacPractice Help window that directs to our HelpDesk site at helpdesk.macpractice.net (This site!)
  • MacPractice Bulletins: This will open up a browser window, directed at our Bulletins page which normally opens when you launch MacPractice. This is used to deliver MacPractice related messages that apply to your office, such as service outages, updates, and other important information. Make a habit of checking this every day to keep informed of anything important to MacPractice!
  • Services and Products: This option opens up a browser window, directed at your Services and Products page which gives you information on the features you have on your license, and any available features that you have not purchased.
  • Request a Billing Service Quote: This option can use the data of your MacPractice database to estimate a quote for our Billing Service. You can learn more about this service here. Please note that this does not send specific claims information. 
  • Release Notes: Opens the Release Notes window, where you can access the release notes for the build of MacPractice you're on.
  • Legal: This will pull up our Legal page.
  • View MacPractice Statement and Make Payments: Opens a prompt to log in and view your statement. If you have any questions regarding this information, don't hesitate to contact Support and ask to speak to Accounting.
  • Show Ticket Window: Opens a window where you can review any outstanding Support Tickets that are currently on your account.
  • Connect To Public: Connects to the MacPractice server.
  • Share Screen: Opens the MacPractice QuickSupport window.
  • Download TeamViewer: This option launches http://www.macpractice.com/teamviewer, from which the share screen software used by MacPractice Support can be download. Please note that this actually will direct you towards downloading Splashtop, our current screen sharing partner.

 

Was this article helpful?
0 out of 0 found this helpful

Comments