Scroll

MacPractice Software and OS Requirements

With the constant influx of new versions of the macOS from Apple, as well as our development team continuing to improve and enhance MacPractice, it can become confusing to determine which build of MacPractice is compatible with which version of the macOS.

The official link to MacPractice System Requirements is here.

What MacPractice Build can I run?

If you are running OS El Capitan (10.11)

You can run MacPractice Build 6.1 and 7.3 (Gen 7). 

Restrictions: Online Patient Scheduling and Reputation Marketing are not usable on Build 6.1.

If you are running OS Sierra (10.12)

You can run MacPractice Build 7.3 (Gen 7) and MacPractice Build 10.7 and up. (Gen 10)

Restrictions: All features work, but for eClaims, eStatements, and TransWorld integration, some tweaks must be made. Please contact MacPractice Support for more details.

If you are running OS High Sierra (10.13)

You can run MacPractice Builds 7.3 and up, including MacPractice 10.7 (Gen 10)

If you are running OS Mojave (10.14)

You can run MacPractice Builds 10.7 and up.

If you are running OS Catalina (10.15)

You can run MacPractice Builds 11 and up.

If you are running OS Big Sur (11)

Please refer to our Big Sur Compatibility page for more information.

Can I update my OS?
If you're thinking about updating your macOS, you'll want to check above to ensure that your Server and Client Computers meet the requirements for the newer version. We advise that you contact MacPractice Support so they can advise you further based on your particular needs.

MacPractice Support cannot assist with the act of updating your OS. If you need assistance or support for macOS issues, please contact Apple Support.

How do I update MacPractice?
See this article for a comprehensive guide to Updating.

Was this article helpful?
1 out of 1 found this helpful

Comments